fbpx

Node-operators drongen er bij aan om niet te upgraden naar de nieuwste versie van een implementatie van een Bitcoin-bliksemnetwerkknooppunt

door | jun 18, 2023 | News

Delen Delen op Twitter Delen op LinkedIn Delen op Telegram Kopiëren Link Link gekopieerd De technologieproductmanager van Lightning Labs, een van de ontwikkelingsbedrijven achter het Lightning Network, heeft gewezen op een geheugenlekbug in de recente Lightning Network Daemon (LND) versie 0.16 .3, en dringt er nu bij operators op aan om niet te upgraden of terug te gaan naar de vorige versie voor degenen die hun software al hebben geüpgraded. Upgrade niet naar LND 0.16.3, de geheugenlek-bug is erg. Als je hebt geüpgraded, kun je veilig terug downgraden naar 0.16.2.— Nitesh ₿⚡️ (@nitesh_btc) 16 juni 2023

De geheugenlekbug in LND versie 0.16.3

De geheugenlekfout ontdekt in LND 0.16.3 kan gevolgen hebben voor operators van knooppunten op het Bitcoin Lightning Network, een laag-2 schaaloplossing voor ’s werelds meest waardevolle blockchain, ingezet door de Lightning Labs. Deze bug veroorzaakt geheugenlekken, wat na verloop van tijd kan leiden tot een grotere vraag naar beschikbaar geheugen. Dit kan leiden tot een geleidelijke toename van de hoeveelheid geheugen die door het programma wordt gebruikt, wat er uiteindelijk toe kan leiden dat het knooppunt crasht, wat gevolgen heeft voor de werking en vooral de betrouwbaarheid. Vervolgens kunnen de risico’s die aan deze bug zijn verbonden de prestaties en stabiliteit van het Lightning Network-knooppunt negatief beïnvloeden, waardoor de verwerking van transacties en de volledige werking van het knooppunt wordt onderbroken.

Beveiliging van het bliksemnetwerk

Als reactie op de fout hebben ontwikkelaars Lightning Network-knooppuntoperators geadviseerd om te wachten met upgraden naar LND 0.16.3 totdat er een oplossing is geïmplementeerd of een stabiele versie beschikbaar is. Hoewel er altijd softwareproblemen zullen zijn in gecompliceerde systemen, vereist de ernst van deze specifieke storing uiterste zorgvuldigheid en snelle behandeling. Specifiek wordt voorgesteld dat degenen die al hebben geüpdatet naar LND versie 0.16.3 downgraden naar versie 0.16.2, wat veilig is. Het is wellicht mogelijk om de stabiliteit van het Lightning Network-knooppunt te herstellen en de risico’s in verband met het geheugenlekprobleem te verminderen door terug te gaan naar een eerdere versie. De Bitcoin-gemeenschap legt sterk de nadruk op informatie over cruciale software-upgrades en bekende kwetsbaarheden. Het consequent monitoren van officiële kanalen, zoals projectrepository’s en communityforums, kan operators helpen om op de hoogte te blijven van de meest recente ontwikkelingen en eventuele problemen die van invloed zijn op hun knooppunten. Op 18 juni waren er 16.389 Bitcoin Lightning Network-knooppunten, terwijl de capaciteit van het Layer-2-platform 5.412,32 BTC bedroeg, een stijging van 2% op de laatste dag. Volg ons op Google Nieuws

Beyond Boundaries

News

Related post

0 reacties

Een reactie versturen

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *

Check onze socials!

Gratis Verzending

Vanaf een bestelling van 40,- 

Veilige Betalingen

Wij bieden een veilige winkelgarantie met klarna en ideal.

Uitgebreid Assortiment

Voor ieder sportdoel de juiste supplementen.

0
    0
    Winkelwagen
    Winkelwagen legenTerug naar Winkel
      Apply Coupon
      Available Coupons
      anna10 Get 10% off
      blackboyfly10 Get 10% off
      hailey10 Get 10% off
      highsky15 Get 15% off 15% korting!
      jerraimke15 Get 15% off
      lisa100 Get 10% off
      olens10 Get 10% off
      ollie10 Get 10% off
      ramon10 Get 10% off
      Unavailable Coupons
      anique10 Get 10% off
      april20 Get 20% off
      jerra10 Get 10% off
      jesse50goals Get 10% off
      jessespitta Get 10% off
      juice10 Get 10% off
      juli15 Get 15% off
      juni10 Get 10% off
      mama1 Get 15% off
      welkom15 Get 15% off